Iris2.de

Iris2-Forum
It is currently Sat Oct 31, 2020 9:43 am

All times are UTC




Post new topic Reply to topic  [ 3 posts ] 
Author Message
PostPosted: Tue Apr 17, 2007 8:49 am 
Offline
User avatar

Joined: Sun Jan 28, 2007 9:09 pm
Posts: 68
I have some problem when i want to compile openal.0.0.8 to run Iris2

Error:

Code:
checking build system type... i686-pc-linux
checking host system type... i686-pc-linux
checking target system type... i686-pc-linux
checking for a BSD-compatible install... /usr/bin/ginstall -c
checking whether build environment is sane... yes
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... configure: error: cannot run C compiled programs.
If you meant to cross compile, use `--host'.
See `config.log' for more details.


config.log file:

Code:
## ----------- ##
## Core tests. ##
## ----------- ##

configure:1622: checking build system type
configure:1640: result: i686-pc-linux
configure:1648: checking host system type
configure:1662: result: i686-pc-linux
configure:1670: checking target system type
configure:1684: result: i686-pc-linux
configure:1712: checking for a BSD-compatible install
configure:1767: result: /usr/bin/ginstall -c
configure:1778: checking whether build environment is sane
configure:1821: result: yes
configure:1886: checking for gawk
configure:1902: found /usr/bin/gawk
configure:1912: result: gawk
configure:1922: checking whether make sets $(MAKE)
configure:1942: result: yes
configure:2187: checking for gcc
configure:2203: found /usr/bin/gcc
configure:2213: result: gcc
configure:2457: checking for C compiler version
configure:2460: gcc --version </dev/null >&5
gcc (GCC) 3.4.6
Copyright (C) 2006 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

configure:2463: $? = 0
configure:2465: gcc -v </dev/null >&5
Reading specs from /usr/lib/gcc/i486-slackware-linux/3.4.6/specs
Configured with: ../gcc-3.4.6/configure --prefix=/usr --enable-shared --enable-threads=posix --enable-__cxa_atexit --disable-checking --with-gnu-ld --verbose --target=i486-slackware-linux --host=i486-slackware-linux
Thread model: posix
gcc version 3.4.6
configure:2468: $? = 0
configure:2470: gcc -V </dev/null >&5
gcc: `-V' option must have argument
configure:2473: $? = 1
configure:2496: checking for C compiler default output file name
configure:2499: gcc    conftest.c  >&5
configure:2502: $? = 0
configure:2548: result: a.out
configure:2553: checking whether the C compiler works
configure:2559: ./a.out
./configure: line 2560: ./a.out: Permission denied
configure:2562: $? = 126
configure:2571: error: cannot run C compiled programs.
If you meant to cross compile, use `--host'.
See `config.log' for more details.


Do u know what i need to do now?

Maybe this will help, but my german lang is basic;)(ich bin Mateusz ;P)
http://www.linux-web.de/thread.php?threadid=12486

_________________
Image


Top
 Profile  
 
 Post subject:
PostPosted: Tue Apr 17, 2007 11:44 am 
Offline
iris2-developer
User avatar

Joined: Tue Apr 18, 2006 10:28 pm
Posts: 823
Location: Munich, Bavaria, Germany
what kind of linux do you have ?
you don't need to compile openal yourself on ubuntu, debian, etc, there is a binary package for it.
(you probably DO need to compile ogre, as we use the newest version available and there probably aren't binary packages for that yet)

try doing this as superuser :
apt-get install libopenal-dev libopenal0a

also on the forum thread you linked the problem was that the harddrive where he wanted to compile was mounted with "noexec" param, so he couldn't execute some program.

if you really have to compile openal, its better to try on a normal linux partition (ext2 ext3 reiser...) than on ntfs, as not all kernels might have full support for the ntfs filesystem yet.

EDIT : by the way, have you tried compiling iris without openal ? we use fmod3.x by default instead of openal


Top
 Profile  
 
 Post subject:
PostPosted: Tue Apr 17, 2007 11:59 am 
Offline
User avatar

Joined: Sun Jan 28, 2007 9:09 pm
Posts: 68
ghoulsblade wrote:
what kind of linux do you have ?
you don't need to compile openal yourself on ubuntu, debian, etc, there is a binary package for it.
(you probably DO need to compile ogre, as we use the newest version available and there probably aren't binary packages for that yet)

I have slacware 11. Then firs i need to compile ogre pkg?

Quote:
try doing this as superuser :
apt-get install libopenal-dev libopenal0a

Nothig happen

Quote:
also on the forum thread you linked the problem was that the harddrive where he wanted to compile was mounted with "noexec" param, so he couldn't execute some program.

Haha! Many thanks @ghouls it was on ext2 then Ive tried to compile in root folder and it works ;).

if you really have to compile openal, its better to try on a normal linux partition (ext2 ext3 reiser...) than on ntfs, as not all kernels might have full support for the ntfs filesystem yet.
Quote:
EDIT : by the way, have you tried compiling iris without openal ? we use fmod3.x by default instead of openal

I need openal when i give command sh ./configure in iris folder there is a warnig.

But its working now ;). It was so simple :P.

_________________
Image


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group