Iris2.de

Iris2-Forum
It is currently Sat Oct 24, 2020 5:15 pm

All times are UTC




Post new topic Reply to topic  [ 14 posts ] 
Author Message
PostPosted: Thu Apr 19, 2007 10:30 am 
Offline

Joined: Thu Apr 19, 2007 10:25 am
Posts: 1
Hello!
How compile sources in MS VS 2005?


Top
 Profile  
 
 Post subject:
PostPosted: Thu Apr 19, 2007 10:36 am 
Offline
iris2-developer
User avatar

Joined: Tue Aug 22, 2006 1:21 pm
Posts: 173
Location: Munich, Germany
http://iris2.de/index.php/Building_From_Source
contains a description how to compile under vc_express. the most difficult part is to collect the libs/dependencies. compiling is almost "add everything and build it".

_________________
O-->---


Top
 Profile  
 
 Post subject:
PostPosted: Thu Apr 19, 2007 12:24 pm 
Offline
iris2-developer
User avatar

Joined: Tue Apr 18, 2006 10:28 pm
Posts: 823
Location: Munich, Bavaria, Germany
vs 2005 is the same as vs8.0 , there is a project file for that in the vc8 directory =)
good luck !


Top
 Profile  
 
 Post subject:
PostPosted: Thu Apr 19, 2007 12:38 pm 
Offline
iris2-developer
User avatar

Joined: Mon Aug 09, 2004 12:20 pm
Posts: 1431
I updated and removed the obsolete sdl_image.dll and zlib.dll binding form the "Building_From_Source". ZLib should be linked as static lib.

You only need the OpenAL bindings if you activate the OpenAL #define.

You find the correct zlib.lib in the Ogre "Visual C++.Net 2005 (8.0) Precompiled Dependencies 1.2.x": http://downloads.sourceforge.net/ogre/OgreDependencies_VC8_1.2.0p2.zip?download


Top
 Profile  
 
 Post subject:
PostPosted: Fri May 04, 2007 11:05 pm 
Offline

Joined: Fri May 04, 2007 11:00 pm
Posts: 1
I've now gotten nearly all dependencies working, but I am unable to get a working LUA 5.0 pkg.

I tried with 5.1.2 but there were some unknown functions/declaritions when I tried compiling iris2. I got the 5.1.2 from http://luabinaries.luaforge.net/download.html, but they only have the most recent LUA there, and I beleive the error may stem from the incorrect version.

Could someone verify this and possibly explain to me how I should built LUA5.0 with VC8 (I've only used MinGW/MSYS for these things).


Top
 Profile  
 
 Post subject:
PostPosted: Sat May 05, 2007 11:16 am 
Offline
iris2-developer
User avatar

Joined: Tue Apr 18, 2006 10:28 pm
Posts: 823
Location: Munich, Bavaria, Germany
trying 5.1.* versions is not going to work out of the box, our code was written for lua 5.0.* and there have been a few api changes, but there should be some options you can set to get backwards compatibility (maybe ./configure help, or edit luaconf.h)
see http://www.lua.org/manual/5.1/manual.html#7 for details.
Quote:
Here we list the incompatibilities that you may found when moving a program from Lua 5.0 to Lua 5.1. You can avoid most of the incompatibilities compiling Lua with appropriate options (see file luaconf.h). However, all these compatibility options will be removed in the next version of Lua.


i use lua 5.0.2-6 , but any 5.0.* should be ok i think.
for lua-sourcecode see
http://www.lua.org/versions.html
for lua-binaries see
http://luaforge.net/frs/?group_id=110
or http://sourceforge.net/project/showfile ... _id=115607
or http://phi.lho.free.fr/index.en.html#downloads


on debian/ubuntu you can get it by
Code:
apt-get install lua50 liblua50 liblua50-dev liblualib50 liblualib50-dev


Top
 Profile  
 
 Post subject:
PostPosted: Thu Dec 27, 2007 5:31 pm 
Offline
Power User
User avatar

Joined: Wed Jun 08, 2005 1:22 pm
Posts: 119
Nevermind, problem solved. Seems that the missing "enviroment variables" "$(LIB)" and "$(INCLUDE)" caused the fatal errors. Im not sure what these should be as ive not set them, but removing them from the "lua50_lib" and "iris" properties fixed the problem. Ill put this to the wiki [url=http://www.iris2.de/index.php/Building_From_Source#building_under_WIN32_with_Visual_C.2B.2B_8.0_Express]Building From Source
[/url] page.


Quote:
As ive already talked about this in the IRC but here goes, perhaps someone can help me out. Im trying to compile Iris on my own, using VC++ 2005 Express. Ive done the first few step from this page. Also ive installed the SP1 and "Microsoft Platform SDK for Windows Server 2003 R2". Ive manually added directories to "VC++ directories" in options and those seem to work as i dont get (many) errors, missing files or directories.

VC++ "Include" directories ive added myself:
Code:
C:\Program Files\OgreSDK\include
C:\Program Files\FMOD SoundSystem\FMOD Programmers API Win32\api\inc
D:\Projects\Iris2\iris2_latest_unstable_repoaccess\lugre\lib\cadune_tree\include
D:\Projects\Iris2\iris2_latest_unstable_repoaccess\lugre\lib\lua-5.0.3\include
C:\Program Files\OgreSDK\Dependencies\include
D:\Projects\Iris2\iris2_latest_unstable_repoaccess\lugre\include
C:\Program Files\Microsoft Platform SDK for Windows Server 2003 R2\Include


Library paths:
Code:
C:\Program Files\FMOD SoundSystem\FMOD Programmers API Win32\api\lib
C:\Program Files\OgreSDK\Dependencies\lib\Release
C:\Program Files\Microsoft Platform SDK for Windows Server 2003 R2\Lib

The "dependencies" folder i just copied from the "dependencies package" i downloaded from Ogre website.

The two errors i get seems to be caused by paths in the "lua50_lib" and "iris" properties called "additional Include directories". Also the "enviroment variables" arent set and im not sure what they are suppose to be set to. "Iris2.exe" with this configuration will not get compiled, so it will be missing altogether.

Heres the saved build log for iris and lua50_lib.

Code:
------ Rebuild All started: Project: lua50_lib, Configuration: Release Win32 ------
Deleting intermediate and output files for project 'lua50_lib', configuration 'Release|Win32'
Compiling...
c1 : fatal error C1083: Cannot open source file: 'C:\Programme\Microsoft Platform SDK\Include\': No such file or directory
lapi.c
..\src\lapi.c(158) : warning C4244: 'return' : conversion from '__w64 int' to 'int', possible loss of data
..\src\lapi.c(834) : warning C4244: 'function' : conversion from '__w64 int' to 'int', possible loss of data
ltablib.c
lstrlib.c
..\src\lib\lstrlib.c(333) : warning C4244: '=' : conversion from '__w64 int' to 'sint32', possible loss of data
..\src\lib\lstrlib.c(530) : warning C4244: 'initializing' : conversion from '__w64 int' to 'int', possible loss of data
loadlib.c
lmathlib.c
liolib.c
..\src\lib\liolib.c(681) : warning C4244: 'function' : conversion from 'time_t' to 'lua_Number', possible loss of data
..\src\lib\liolib.c(698) : warning C4244: 'function' : conversion from 'time_t' to 'lua_Number', possible loss of data
ldblib.c
lbaselib.c
lauxlib.c
lzio.c
lvm.c
..\src\lvm.c(745) : warning C4244: '=' : conversion from '__w64 int' to 'int', possible loss of data
lundump.c
..\src\lundump.c(43) : warning C4267: 'initializing' : conversion from 'size_t' to 'int', possible loss of data
..\src\lundump.c(52) : warning C4267: 'initializing' : conversion from 'size_t' to 'int', possible loss of data
..\src\lundump.c(56) : warning C4267: 'function' : conversion from 'size_t' to 'int', possible loss of data
..\src\lundump.c(67) : warning C4267: 'initializing' : conversion from 'size_t' to 'int', possible loss of data
..\src\lundump.c(73) : warning C4267: 'function' : conversion from 'size_t' to 'int', possible loss of data
..\src\lundump.c(106) : warning C4267: 'function' : conversion from 'size_t' to 'int', possible loss of data
ltm.c
ltests.c
ltable.c
..\src\ltable.c(108) : warning C4311: 'type cast' : pointer truncation from 'void *const ' to 'lu_hash'
..\src\ltable.c(110) : warning C4311: 'type cast' : pointer truncation from 'GCObject *const ' to 'lu_hash'
lstring.c
lstate.c
lparser.c
lopcodes.c
Generating Code...
Compiling...
lobject.c
..\src\lobject.c(147) : warning C4244: 'function' : conversion from '__w64 int' to 'int', possible loss of data
..\src\lobject.c(173) : warning C4267: '=' : conversion from 'size_t' to 'int', possible loss of data
..\src\lobject.c(182) : warning C4267: 'initializing' : conversion from 'size_t' to 'int', possible loss of data
lmem.c
llex.c
lgc.c
..\src\lgc.c(229) : warning C4244: 'initializing' : conversion from '__w64 int' to 'int', possible loss of data
..\src\lgc.c(233) : warning C4244: '=' : conversion from '__w64 int' to 'int', possible loss of data
lfunc.c
ldump.c
ldo.c
..\src\ldo.c(97) : warning C4244: 'initializing' : conversion from '__w64 int' to 'int', possible loss of data
..\src\ldo.c(168) : warning C4244: '=' : conversion from '__w64 int' to 'int', possible loss of data
..\src\ldo.c(187) : warning C4244: 'initializing' : conversion from '__w64 int' to 'int', possible loss of data
ldebug.c
..\src\ldebug.c(110) : warning C4244: '=' : conversion from '__w64 int' to 'int', possible loss of data
..\src\ldebug.c(519) : warning C4244: 'function' : conversion from '__w64 int' to 'int', possible loss of data
lcode.c
Generating Code...
Project : warning PRJ0018 : The following environment variables were not found:
$(INCLUDE)
Build log was saved at "file://d:\Projects\Iris2\iris2_latest_unstable_repoaccess\lugre\lib\lua-5.0.3\obj\lua50_lib\Release\BuildLog.htm"
lua50_lib - 1 error(s), 25 warning(s)
------ Rebuild All started: Project: iris, Configuration: Release Win32 ------
Deleting intermediate and output files for project 'iris', configuration 'Release|Win32'
Compiling...
c1xx : fatal error C1083: Cannot open source file: 'C:\Program Files\OgreSDK\include\': No such file or directory
CTStem.cpp
CTSerializer.cpp
CTSection.cpp
CTParameters.cpp
lugre_widget_L.cpp
lugre_widget.cpp
lugre_viewport_L.cpp
lugre_transform_mesh.cpp
lugre_timer.cpp
lugre_thread_L.cpp
lugre_thread.cpp
lugre_sound_L.cpp
lugre_sound_fmod.cpp
lugre_sound.cpp
lugre_SortedOverlayContainer.cpp
lugre_shell.cpp
lugre_scripting.ogre.cpp
lugre_scripting.general.cpp
lugre_scripting.cpp
Compiling...
lugre_robstring.cpp
lugre_RobRenderableOverlay.cpp
lugre_robrenderable.cpp
lugre_rendertexture_L.cpp
lugre_random_L.cpp
lugre_random.cpp
lugre_profile.cpp
..\lugre\src\lugre_profile.cpp(63) : warning C4312: 'reinterpret_cast' : conversion from 'long' to 'void *' of greater size
..\lugre\src\lugre_profile.cpp(112) : warning C4311: 'reinterpret_cast' : pointer truncation from 'void *' to 'long'
..\lugre\src\lugre_profile.cpp(123) : warning C4311: 'reinterpret_cast' : pointer truncation from 'void *' to 'long'
lugre_ogrewrapper.cpp
lugre_ode_L.cpp
lugre_ode.cpp
lugre_net_L.cpp
..\lugre\src\lugre_net_L.cpp(104) : warning C4312: 'reinterpret_cast' : conversion from 'Lugre::uint32' to 'void *' of greater size
..\lugre\src\lugre_net_L.cpp(215) : warning C4312: 'reinterpret_cast' : conversion from 'Lugre::uint32' to 'void *' of greater size
..\lugre\src\lugre_net_L.cpp(257) : warning C4311: 'type cast' : pointer truncation from 'void *' to 'long'
lugre_net.cpp
lugre_meshshape.cpp
lugre_material_L.cpp
lugre_main.cpp
lugre_luaxml.cpp
lugre_listener.cpp
lugre_input.cpp
lugre_gfx3D_L.cpp
lugre_gfx3D.cpp
Compiling...
lugre_gfx2D_L.cpp
lugre_gfx2D.cpp
lugre_game.cpp
lugre_fifo_L.cpp
..\lugre\src\lugre_fifo_L.cpp(103) : warning C4311: 'type cast' : pointer truncation from 'Lugre::cFIFO *' to 'long'
lugre_CompassOverlay.cpp
lugre_ColourClipTextOverlay.cpp
lugre_ColourClipPaneOverlay.cpp
lugre_camera_L.cpp
lugre_cadune_L.cpp
lugre_BorderColourClipPaneOverlay.cpp
lugre_bitmask_L.cpp
lugre_bitmask.cpp
lugre_beam_L.cpp
lugre_beam.cpp
terrain_multitex.cpp
terrain.cpp
spritemanager_L.cpp
spritemanager.cpp
scripting.iris.cpp
radar_L.cpp
Compiling...
radar.cpp
prefix.cpp
pathsearch.cpp
ogremanualloader_L.cpp
ogremanualloader.cpp
main.cpp
huffman.cpp
grannyparser.cpp
grannyogreloader.cpp
grannyloader_i2.cpp
grannydump.cpp
granny_L.cpp
data_L.cpp
..\src\data_L.cpp(398) : warning C4313: 'printf' : '%x' in format string conflicts with argument 2 of type 'cStaticTileType *'
..\src\data_L.cpp(398) : warning C4313: 'printf' : '%x' in format string conflicts with argument 3 of type 'RawStaticTileType *'
data.cpp
builder_L.cpp
builder.cpp
Project : warning PRJ0018 : The following environment variables were not found:
$(LIB)
$(INCLUDE)
Build log was saved at "file://d:\Projects\Iris2\iris2_latest_unstable_repoaccess\vs8\Release\BuildLog.htm"
iris - 1 error(s), 9 warning(s)
========== Rebuild All: 0 succeeded, 2 failed, 0 skipped ==========


Top
 Profile  
 
 Post subject:
PostPosted: Fri Dec 28, 2007 10:29 pm 
Offline
iris2-developer
User avatar

Joined: Mon Aug 09, 2004 12:20 pm
Posts: 1431
I think then your installation of the Microsoft PSDK is wrong or do you take VS2005 Full Edition (not express)?

The "enviroment variables" "$(LIB)" and "$(INCLUDE)" are for the MS PSDK using Vs2005 Express.

_________________
http://crankgaming.blogspot.com/ | https://twitter.com/#!/crank_gaming


Top
 Profile  
 
 Post subject:
PostPosted: Fri Dec 28, 2007 10:54 pm 
Offline
Power User
User avatar

Joined: Wed Jun 08, 2005 1:22 pm
Posts: 119
Well the compiled exe seems to work just fine. Im using the 2005 Express Edition with the SP1 installed. Also...

http://msdn2.microsoft.com/en-us/library/ms235626(VS.80).aspx

In above link they link here where they mention the following.

Quote:
This is no longer the most recent edition of the Platform SDK, please download the Windows Server 2003 R2 SDK - March 2006 Edition, (see related resources)


Quote:
This edition of the SDK replaces the previous SDKs for Windows XP SP2 and Windows Server 2003 and can be used to develop applications for those platforms.


"Microsoft Platform SDK for Windows Server 2003 R2" is what ive installed, the recent one.


Top
 Profile  
 
 Post subject:
PostPosted: Sat Dec 29, 2007 12:18 am 
Offline
iris2-developer
User avatar

Joined: Tue Apr 18, 2006 10:28 pm
Posts: 823
Location: Munich, Bavaria, Germany
oh i remember, the newer version needed some kind of authorization crap, so i used the old one, at least for building sfz.


Top
 Profile  
 
 Post subject:
PostPosted: Sat Dec 29, 2007 10:21 am 
Offline
Power User
User avatar

Joined: Wed Jun 08, 2005 1:22 pm
Posts: 119
To be exact, i got this one which is a .img file.


Top
 Profile  
 
 Post subject:
PostPosted: Sat Dec 29, 2007 12:26 pm 
Offline
iris2-developer
User avatar

Joined: Mon Aug 09, 2004 12:20 pm
Posts: 1431
I use exactly this Version (Windows Server 2003 R2 SDK - March 2006 Edition) and have no problems!

Take a look at your environment variables if thier path is correct.

INCLUDE
C:\Programme\Microsoft Platform SDK for Windows Server 2003 R2\Include\.


LIB
C:\Programme\Microsoft Platform SDK for Windows Server 2003 R2\Lib\.


so it should be.


Top
 Profile  
 
 Post subject:
PostPosted: Sun Dec 30, 2007 8:35 pm 
Offline
Power User
User avatar

Joined: Wed Jun 08, 2005 1:22 pm
Posts: 119
Ive got those paths added in the "VC++ Directories" along with all the other which caused the compile to fail. I dont have "INCLUDE" or "LIB" enviroment paths set, i could add those manually i guess(?).


Top
 Profile  
 
 Post subject:
PostPosted: Mon Dec 31, 2007 12:21 pm 
Offline
iris2-developer
User avatar

Joined: Mon Aug 09, 2004 12:20 pm
Posts: 1431
Of couse.

go Start->System Settings->System->Environment Vars. and set them there.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 14 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group