Iris2.de

Iris2-Forum
It is currently Sat Oct 24, 2020 5:34 pm

All times are UTC




Post new topic Reply to topic  [ 23 posts ]  Go to page Previous  1, 2
Author Message
 Post subject:
PostPosted: Sun Aug 17, 2008 10:18 pm 
Offline
Power User
User avatar

Joined: Thu Jun 10, 2004 4:01 pm
Posts: 152
Location: Brasil
All right! Now I can to compile iris2 :D
I continue with problem to connect on UO shards in my 64bits system but now I can start in offline with -2d option. I know that iris2 don't support 64bits but look what I get on console... The problem may be with other thing.

Code:
DEBUG   ../uo/map0.mul  fc97b6fb247559cad54ee4cf7c48250f
DEBUG   ../uo/staidx0.mul       23655ce6b4aa4ef29b4b24e9c7ec28ad
DEBUG   ../uo/statics0.mul      49ad09a228e37b084bbbddfdd3ada7d5
../data/tmp/compass_4b102f015fb6634609945dea0ba09eb3_small_s.png exists
###### TODO lib.diff.lua : enable diff  1       0       0
###### TODO lib.diff.lua : enable diff  2       0       0
###### TODO lib.diff.lua : enable diff  3       0       0
###### TODO lib.diff.lua : enable diff  0       0       0
WalkLog t=    0 k= 0 r= 0       NotifyTeleport start
WalkLog t=    0 k= 0 r= 0       ResetWalkQueue start
WalkLog t=    0 k= 0 r= 0       ResetWalkQueue end
MultiTexTerrain_NotifyTeleport
WalkLog t=    0 k= 0 r= 0       NotifyTeleport end
TODO:GumpParser_CloseOldDialog
(0) : fatal error C9999: *** exception during compilation ***
Cg compiler terminated due to fatal error~/Download/iris2svn


And here you can see the backtrace option on gdb:

Code:
TODO:GumpParser_CloseOldDialog

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0x7f2748922700 (LWP 6258)]
0x000000000045f7d8 in ?? ()
(gdb) bt
#0  0x000000000045f7d8 in ?? ()
#1  0x000000000047a3e7 in ?? ()
#2  0x000000000059f6e6 in ?? ()
#3  0x00000000005abcd1 in ?? ()
#4  0x000000000059fc55 in ?? ()
#5  0x000000000059f2d7 in ?? ()
#6  0x000000000059f355 in ?? ()
#7  0x000000000059d7a2 in ?? ()
#8  0x00000000004b2e68 in ?? ()
#9  0x00000000004b3201 in ?? ()
#10 0x00000000004bd9fb in ?? ()
#11 0x00000000004fdf36 in ?? ()
#12 0x0000000000484f71 in ?? ()
#13 0x00007f274738f436 in __libc_start_main () from /lib64/libc.so.6
#14 0x0000000000417a49 in ?? ()
#15 0x00007fff5095ea28 in ?? ()
#16 0x000000000000001c in ?? ()
#17 0x0000000000000002 in ?? ()
#18 0x00007fff50960486 in ?? ()
#19 0x00007fff509604ac in ?? ()
#20 0x0000000000000000 in ?? ()


Thanks very much by help!! :D

_________________
Please, they answer to my questions in Portuguese or the formal English, therefore I use google to translate them.

Thanks.


Top
 Profile  
 
 Post subject:
PostPosted: Mon Aug 18, 2008 11:10 am 
Offline
iris2-developer
User avatar

Joined: Tue Apr 18, 2006 10:28 pm
Posts: 823
Location: Munich, Bavaria, Germany
Quote:
Cg compiler terminated due to fatal error~/Download/iris2svn


looks like a problem with one of the shaders,
please check the bin/Ogre.log file.

adding a line
Code:
gGraphicProfile = "low"

to the config.lua might also help


Top
 Profile  
 
 Post subject:
PostPosted: Mon Aug 18, 2008 1:50 pm 
Offline
iris2-developer
User avatar

Joined: Mon Aug 09, 2004 12:20 pm
Posts: 1431
Normally (standard configuration) shader are inactive.

If you choose graphicprofile "ultralow", "low", "med" you have no shaders.

Profile "high" and "ultrahigh" use shaders for caelumsky. You prob. need a shader 3.0 card for this.


Top
 Profile  
 
 Post subject:
PostPosted: Mon Aug 18, 2008 11:16 pm 
Offline
Power User
User avatar

Joined: Thu Jun 10, 2004 4:01 pm
Posts: 152
Location: Brasil
My graphic card is a gforce Go 7400. I tested with low option but the error continue. You can get my Ogre.log on this link http://iurigules.googlepages.com/Ogre.log

Thanks ;)

_________________
Please, they answer to my questions in Portuguese or the formal English, therefore I use google to translate them.

Thanks.


Top
 Profile  
 
 Post subject:
PostPosted: Tue Aug 19, 2008 1:27 am 
Offline
iris2-developer
User avatar

Joined: Tue Apr 18, 2006 10:28 pm
Posts: 823
Location: Munich, Bavaria, Germany
the shaders aren't used ingame, but the segfaults seems to appear during shader compilation, in the cg compiler.

ogre loads and compiles all the shaders even if they aren't used.

either you can try to fix your cgtools, e.g. look for an update or a 64 bit version, or totally deactivate shader loading for iris :

please try editing
bin/plugins_linux.cfg
and remove the line

Plugin=Plugin_CgProgramManager.so

then it shouldn't even try to load the shaders..


Top
 Profile  
 
 Post subject:
PostPosted: Tue Aug 19, 2008 11:34 pm 
Offline
Power User
User avatar

Joined: Thu Jun 10, 2004 4:01 pm
Posts: 152
Location: Brasil
Well... without this line e get a segfaul but now I think that the problem is with 64bits system :/
Code:
lugre/src/lugre_main.cpp:182:Lugre_Run
lugre/src/lugre_game.cpp:19:Run
  lugre/src/lugre_scripting.cpp:263:LuaCall
   lugre/src/lugre_scripting.cpp:187:PCallWithErrFuncWrapper
    src/data_gump_L.cpp:76:ExportToImage
     include/data_gump.h:8:Decode
PrintLuaStackTrace:
LuaStackTrace:

        [C]: in function `ExportToImage'
        ../lua/lib.iris_atlasgroup.lua:37: in function `LoadImpl'
        ../lugre/lua/lib.atlasgroup.lua:25: in function `LoadToAtlas'
        ../lugre/lua/lib.atlasgroup.lua:17: in function `PreLoad'
        ../lua/lib.iris_atlasgroup.lua:11: in function `PreLoadGump'
        ../lua/gui/gui.gumpparser.lua:262: in function <../lua/gui/gui.gumpparser.lua:227>
        (tail call): ?
        ../lua/gui/gui.healthbar.lua:144: in function `OpenHealthbar'
        ../lua/net.walk.lua:321: in function `NotifyTeleport'
        ../lua/net/net.mobile.lua:101: in function `handler'
        ../lua/lib.protocol.lua:73: in function `HandlePackets'
        ../lua/lib.net.lua:91: in function `NetStep'
        ../lua/main.lua:397: in function `MainStep'
        ../lua/main.lua:353: in function <../lua/main.lua:277>
ERROR : SegFault Detected


bt option from gdb:
Code:
(gdb) bt
#0  0x00007fade84375c5 in raise () from /lib64/libc.so.6
#1  0x00007fade8438bb3 in abort () from /lib64/libc.so.6
#2  0x00000000004fe0e2 in ?? ()
#3  <signal handler called>
#4  0x000000000045fa98 in ?? ()
#5  0x000000000047a6a7 in ?? ()
#6  0x000000000059f2e6 in ?? ()
#7  0x00000000005ab8d1 in ?? ()
#8  0x000000000059f855 in ?? ()
#9  0x000000000059eed7 in ?? ()
#10 0x000000000059ef55 in ?? ()
#11 0x000000000059d3a2 in ?? ()
#12 0x00000000004b3128 in ?? ()
#13 0x00000000004b34c1 in ?? ()
#14 0x00000000004bdcbb in ?? ()
#15 0x00000000004fe1f6 in ?? ()
#16 0x0000000000485231 in ?? ()
#17 0x00007fade8423436 in __libc_start_main () from /lib64/libc.so.6
#18 0x0000000000417d09 in ?? ()
#19 0x00007ffff19f4968 in ?? ()
#20 0x000000000000001c in ?? ()
#21 0x0000000000000002 in ?? ()
#22 0x00007ffff19f533f in ?? ()
---Type <return> to continue, or q <return> to quit---
#23 0x00007ffff19f5365 in ?? ()
#24 0x0000000000000000 in ?? ()
(gdb) c


Thanks by patience.

_________________
Please, they answer to my questions in Portuguese or the formal English, therefore I use google to translate them.

Thanks.


Top
 Profile  
 
 Post subject:
PostPosted: Tue Aug 19, 2008 11:44 pm 
Offline
iris2-developer
User avatar

Joined: Tue Apr 18, 2006 10:28 pm
Posts: 823
Location: Munich, Bavaria, Germany
yep, looks like 64 bit trouble.
Sorry, no idea how to resolve this, it seems to crash in one of ogre's libs for writing images to disk or so.
Aren't 64 bit systems supposed to be backwards compatible ?
Is there maybe some compiler option for 32-bit-compatibility mode or so ?

maybe you can ask on your distro forums what to do when you have trouble compiling something on 64 bit.


Top
 Profile  
 
 Post subject:
PostPosted: Wed Aug 20, 2008 7:44 pm 
Offline
Power User
User avatar

Joined: Thu Jun 10, 2004 4:01 pm
Posts: 152
Location: Brasil
Well... I don't have time to resolve it at this moment. But when I have time I will try. I think that the -m32 gcc option do a 32bit compilation.

_________________
Please, they answer to my questions in Portuguese or the formal English, therefore I use google to translate them.

Thanks.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 23 posts ]  Go to page Previous  1, 2

All times are UTC


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group