Iris2.de

Iris2-Forum
It is currently Sat Oct 24, 2020 6:09 pm

All times are UTC




Post new topic Reply to topic  [ 3 posts ] 
Author Message
 Post subject: Problems Compiling
PostPosted: Mon Dec 29, 2008 12:32 am 
Offline

Joined: Mon Dec 29, 2008 12:29 am
Posts: 4
I am trying to build iris from the stable_release branch in SVN, but I get the following error:

Code:
src/spritemanager.cpp: In member function ‘void cSpriteManager::prepareForRender()’:
src/spritemanager.cpp:271: error: no matching function for call to ‘Ogre::RenderSystem::_setAlphaRejectSettings(Ogre::CompareFunction, int)’
/usr/local/include/OGRE/OgreRenderSystem.h:664: note: candidates are: virtual void Ogre::RenderSystem::_setAlphaRejectSettings(Ogre::CompareFunction, unsigned char, bool)
make[1]: *** [obj/Release/spritemanager.o] Error 1
make: *** [iris] Error 2


I assume this is an OGRE version mismatch? I originally tried to build from the iris tar source file but I had a different error. I am on ubuntu 8.10 and I am using ogre 1.6.0.

Thanks,
Gordon

Btw thanks for building this client and I am excited to get it working.[/code]


Top
 Profile  
 
 Post subject:
PostPosted: Mon Dec 29, 2008 3:20 am 
Offline

Joined: Mon Dec 29, 2008 12:29 am
Posts: 4
I fixed this by using Ogre 1.4.9 from the synaptic package manager.

I later realized that I probably forgot this step that I found in the INSTALL file and not in the online wiki:

Code:
=== to use ogre 1.6.* (shoggoth) instead of 1.4.* ===
   * in lugre folder: patch -p0 < patches/shoggoth.patch
   * in data folder: patch -p0 < shoggoth_patch


This should probably be added to the wiki since it lists Ogre 1.6.x as a prerequisite but does not include the above which lead to some confusion.

Now lets see if I can get this to work with my shard.

Thanks,
Gordon


Top
 Profile  
 
 Post subject:
PostPosted: Mon Dec 29, 2008 1:12 pm 
Offline
iris2-developer
User avatar

Joined: Tue Apr 18, 2006 10:28 pm
Posts: 823
Location: Munich, Bavaria, Germany
that will be solved in the next stable release as trunk already uses ogre1.6 already, the next stable release will use also require ogre1.6, the current one is the last one supporting ogre1.4.* =)

probably in a few weeks, you can add a note to the wiki if you like, that's what it's editable for =)


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group