Iris2.de

Iris2-Forum
It is currently Fri Oct 30, 2020 1:14 am

All times are UTC




Post new topic Reply to topic  [ 5 posts ] 
Author Message
 Post subject: Another SegFault bug :(
PostPosted: Mon Sep 15, 2008 10:05 pm 
Offline

Joined: Sat Apr 01, 2006 10:53 pm
Posts: 63
Location: AL, USA
Hagish fixed one of the seg fault bugs but apparently there is still one I think its possible caused by the animation system.

Code:
##################################
######      START INGAME     #####
##################################
none
Welcome to Iris
stop music
TODO:GumpParser_CloseOldDialog
NET: kPacket_Generic_Command size=0x0006 subcmd=0x0008=kPacket_Generic_SubComman
d_MapChange
NET: kPacket_Generic_Command size=0x000c subcmd=0x0019=kPacket_Generic_SubComman
d_ExtendedStats
warning : terrain : groundblock loader doesn't support group loading, falling ba
ck to copy, but it's a bit slower (group loading not implemented yet)
WARNING ! playing anim 'Pillage' failed
WARNING ! length check for anim 'Pillage' failed
WARNING ! playing anim 'Pillage' failed
WARNING ! length check for anim 'Pillage' failed
gTileFreeWalk:StuckFix
..\lugre\src\lugre_main.cpp:182:Lugre::Lugre_Run
..\lugre\src\lugre_game.cpp:19:Lugre::cGame::Run
  ..\lugre\src\lugre_scripting.cpp:263:Lugre::cScripting::LuaCall
   ..\lugre\src\lugre_scripting.cpp:187:Lugre::PCallWithErrFuncWrapper
    ..\lugre\src\lugre_scripting.ogre.cpp:416:l_Client_RenderOneFrame
     ..\lugre\src\lugre_game.cpp:35:Lugre::cGame::RenderOneFrame
      ..\lugre\src\lugre_ogrewrapper.cpp:603:Lugre::cOgreWrapper::RenderOneFrame

PrintLuaStackTrace:
LuaStackTrace:

        [C]: in function `Client_RenderOneFrame'
        ..//lua/main.lua:435: in function `MainStep'
        ..//lua/main.lua:361: in function <..//lua/main.lua:285>
ERROR : SegFault Detected
If this error remains after running the updater and you think this is a bug
please check the BugTracker at www.iris2.de
and report it if it is not already known.
Please also append the logfile in bin/stacktrace.log to your bugreport.


Top
 Profile  
 
 Post subject:
PostPosted: Tue Sep 16, 2008 11:38 am 
Offline
iris2-developer
User avatar

Joined: Mon Aug 09, 2004 12:20 pm
Posts: 1431
Remember that we always have the shader seg-fault bug. so don't turn on shaders at all to search bugs. otherwise it can be always this shader seg-fault. i don't think thats an animation seg-fault bug, but who knows :-).


Top
 Profile  
 
 Post subject:
PostPosted: Tue Sep 16, 2008 7:52 pm 
Offline

Joined: Sat Apr 01, 2006 10:53 pm
Posts: 63
Location: AL, USA
Here is a debug of the animation.

Code:
##################################
######      START INGAME     #####
##################################
none
Welcome to Iris
stop music
TODO:GumpParser_CloseOldDialog
NET: kPacket_Generic_Command size=0x0006 subcmd=0x0008=kPacket_Generic_SubComman
d_MapChange
NET: kPacket_Generic_Command size=0x000c subcmd=0x0019=kPacket_Generic_SubComman
d_ExtendedStats
DEBUG[animation]        Animation m_animForward=0,m_animation=5,m_frameDelay=1,m
_framecount=5,m_repeat=1,m_repeatFlag=1,mobileserial=5595,
warning : terrain : groundblock loader doesn't support group loading, falling ba
ck to copy, but it's a bit slower (group loading not implemented yet)
gTileFreeWalk:StuckFix
DEBUG[animation]        Animation m_animForward=0,m_animation=10,m_frameDelay=1,
m_framecount=5,m_repeat=1,m_repeatFlag=0,mobileserial=4204,
DEBUG[animation]        Animation m_animForward=0,m_animation=10,m_frameDelay=1,
m_framecount=5,m_repeat=1,m_repeatFlag=0,mobileserial=4040,
DEBUG[animation]        Animation m_animForward=0,m_animation=10,m_frameDelay=1,
m_framecount=5,m_repeat=1,m_repeatFlag=0,mobileserial=4192,
DEBUG[animation]        Animation m_animForward=0,m_animation=11,m_frameDelay=1,
m_framecount=5,m_repeat=1,m_repeatFlag=0,mobileserial=4145,
WARNING ! playing anim 'Pillage' failed
WARNING ! length check for anim 'Pillage' failed
..\lugre\src\lugre_main.cpp:182:Lugre::Lugre_Run
..\lugre\src\lugre_game.cpp:19:Lugre::cGame::Run
  ..\lugre\src\lugre_scripting.cpp:263:Lugre::cScripting::LuaCall
   ..\lugre\src\lugre_scripting.cpp:187:Lugre::PCallWithErrFuncWrapper
    ..\lugre\src\lugre_scripting.ogre.cpp:416:l_Client_RenderOneFrame
     ..\lugre\src\lugre_game.cpp:35:Lugre::cGame::RenderOneFrame
      ..\lugre\src\lugre_ogrewrapper.cpp:603:Lugre::cOgreWrapper::RenderOneFrame

PrintLuaStackTrace:
LuaStackTrace:

        [C]: in function `Client_RenderOneFrame'
        ..//lua/main.lua:435: in function `MainStep'
        ..//lua/main.lua:361: in function <..//lua/main.lua:285>
ERROR : SegFault Detected
If this error remains after running the updater and you think this is a bug
please check the BugTracker at www.iris2.de
and report it if it is not already known.
Please also append the logfile in bin/stacktrace.log to your bugreport.


EDIT: I just had another segfault that didn't have anything animation related before it so possible could be caused by this "gTileFreeWalk:StuckFix" which seems to be in all 4 of my segfault errors since i've been keeping track


Top
 Profile  
 
 Post subject:
PostPosted: Tue Sep 16, 2008 11:59 pm 
Offline
iris2-developer
User avatar

Joined: Tue Apr 18, 2006 10:28 pm
Posts: 823
Location: Munich, Bavaria, Germany
the "WARNING ! length check for anim 'Pillage' failed" before the crash doesn't mean that the crash is animation related.

it occurs inside "[C]: in function `Client_RenderOneFrame'" so it could be basically anything 3d related.

sadly it's hard to locate the problem in this case, you could try playing around with gdb and compiling ogre with debug infos, and then try to get a more useful stacktrace with gdb under linux, or whatever debug system you have available. But don't ask me how, i don't know the ogre build system well enough to be any help here.

other than that : try disabling the watershader via config and try to reproduce the crash.


Top
 Profile  
 
 Post subject:
PostPosted: Wed Sep 17, 2008 4:02 am 
Offline

Joined: Sat Apr 01, 2006 10:53 pm
Posts: 63
Location: AL, USA
Ok well maybe sience can help with that I'll try the water shader again.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 5 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group