Iris2.de

Iris2-Forum
It is currently Sat Oct 31, 2020 8:01 pm

All times are UTC




Post new topic Reply to topic  [ 6 posts ] 
Author Message
PostPosted: Fri Dec 19, 2008 1:33 pm 
Offline

Joined: Fri Dec 19, 2008 1:26 pm
Posts: 4
Got this error when i try to start... My system is: Ubuntu 32 bit. Video - NVidia GeForce 7300 GT.

Code:
~/Desktop/iris_2.0.2702/bin ~/Desktop/iris_2.0.2702
MainWorkingDir   ../
lugreluapath   ../lugre/lua/
gGraphicProfile shadow   med
Setting Graphicprofile: ../data/profiles/gfx_med.lua
Lua version : 5.1
loading plugin    ../plugins/example.lua
loading plugin    ../plugins/hudenemylist.lua
loading plugin    ../plugins/lib.spellbar.lua
loading plugin    ../plugins/loot.lua
loading plugin    ../plugins/moblist.lua
lugre/src/lugre_main.cpp:189:Lugre_Run
lugre/src/lugre_game.cpp:19:Run
  lugre/src/lugre_scripting.cpp:263:LuaCall
   lugre/src/lugre_scripting.cpp:187:PCallWithErrFuncWrapper
    lugre/src/lugre_scripting.ogre.cpp:189:l_InitOgre
     lugre/src/lugre_ogrewrapper.cpp:299:Init
PrintLuaStackTrace:
LuaStackTrace:

   [C]: in function `InitOgre'
   ../lua/main.lua:345: in function <../lua/main.lua:310>
ERROR : SegFault Detected
If this error remains after running the updater and you think this is a bug
please check the BugTracker at www.iris2.de
and report it if it is not already known.
Please also append the logfile in bin/stacktrace.log to your bugreport.
./start.sh: line 5: 31368 Aborted                 ./iris $1 $2 $3 $4 $5 $6 $7 $8
~/Desktop/iris_2.0.2702


and here is my bin/stacktrace.log

Code:
:: Fri Dec 19 15:11:31 2008

SegFault Detected
lugre/src/lugre_main.cpp:189:Lugre_Run
lugre/src/lugre_game.cpp:19:Run
  lugre/src/lugre_scripting.cpp:263:LuaCall
   lugre/src/lugre_scripting.cpp:187:PCallWithErrFuncWrapper
    lugre/src/lugre_scripting.ogre.cpp:189:l_InitOgre
     lugre/src/lugre_ogrewrapper.cpp:299:Init
PrintLuaStackTrace:
LuaStackTrace:

   [C]: in function `InitOgre'
   ../lua/main.lua:345: in function <../lua/main.lua:310>

+some more but there's no difference but time )


Top
 Profile  
 
 Post subject:
PostPosted: Fri Dec 19, 2008 7:42 pm 
Offline
iris2-developer
User avatar

Joined: Tue Apr 18, 2006 10:28 pm
Posts: 823
Location: Munich, Bavaria, Germany
hmm, you can try to delete bin/ogre.cfg and start using different gfx options, try fullscreen=no , FSAA = 0 ,
rtt preferred mode = copy and a not too big resolution, e.g. 1024 x 768.


Top
 Profile  
 
 Post subject:
PostPosted: Mon Dec 22, 2008 9:23 am 
Offline

Joined: Fri Dec 19, 2008 1:26 pm
Posts: 4
there is only ogre.log in bin dir

Code:
11:19:28: Creating resource group General
11:19:28: Creating resource group Internal
11:19:28: Creating resource group Autodetect
11:19:28: SceneManagerFactory for type 'DefaultSceneManager' registered.
11:19:28: Registering ResourceManager for type Material
11:19:28: Registering ResourceManager for type Mesh
11:19:28: Registering ResourceManager for type Skeleton
11:19:28: MovableObjectFactory for type 'ParticleSystem' registered.
11:19:28: OverlayElementFactory for type Panel registered.
11:19:28: OverlayElementFactory for type BorderPanel registered.
11:19:28: OverlayElementFactory for type TextArea registered.
11:19:28: Registering ResourceManager for type Font
11:19:28: ArchiveFactory for archive type FileSystem registered.
11:19:28: ArchiveFactory for archive type Zip registered.
11:19:28: FreeImage version: 3.10.0
11:19:28: This program uses FreeImage, a free, open source image library supporting all common bitmap formats. See http://freeimage.sourceforge.net for details
11:19:28: Supported formats: bmp,ico,jpg,jif,jpeg,jpe,jng,koa,iff,lbm,mng,pbm,pbm,pcd,pcx,pgm,pgm,png,ppm,ppm,ras,tga,targa,tif,tiff,wap,wbmp,wbm,psd,cut,xbm,xpm,gif,hdr,g3,sgi,exr,j2k,j2c,jp2
11:19:28: DDS codec registering
11:19:28: Registering ResourceManager for type HighLevelGpuProgram
11:19:28: Registering ResourceManager for type Compositor
11:19:28: MovableObjectFactory for type 'Entity' registered.
11:19:28: MovableObjectFactory for type 'Light' registered.
11:19:28: MovableObjectFactory for type 'BillboardSet' registered.
11:19:28: MovableObjectFactory for type 'ManualObject' registered.
11:19:28: MovableObjectFactory for type 'BillboardChain' registered.
11:19:28: MovableObjectFactory for type 'RibbonTrail' registered.
11:19:28: *-*-* OGRE Initialising
11:19:28: *-*-* Version 1.4.9 (Eihort)
11:19:28: Loading library /usr/local/lib/OGRE/RenderSystem_GL.so


windows Iris2.exe in bin dir works just fine. it creates ogre.cfg but ./start.sh still got the same problem =\


Top
 Profile  
 
 Post subject:
PostPosted: Mon Dec 22, 2008 11:32 am 
Offline
iris2-developer
User avatar

Joined: Tue Apr 18, 2006 10:28 pm
Posts: 823
Location: Munich, Bavaria, Germany
i've got kubuntu 8.04 (hardy), 32 bit, NVidia GeForce 9500M GS, and it works fine.
maybe different drivers ? i used EnvyNG to install drivers.


Top
 Profile  
 
 Post subject:
PostPosted: Mon Dec 22, 2008 11:56 am 
Offline

Joined: Fri Dec 19, 2008 1:26 pm
Posts: 4
duno ) i use the ones that ubuntu installs ) all the games works fine... compiz works good too...


Top
 Profile  
 
 Post subject:
PostPosted: Tue Dec 23, 2008 9:22 am 
Offline

Joined: Fri Dec 19, 2008 1:26 pm
Posts: 4
ok...i've installed Envy... it says that dviver 173 is recomended...and i had driver 177...
i've installed 173 and there is the same problem again :(


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 6 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group