Iris2.de

Iris2-Forum
It is currently Sat Oct 31, 2020 7:50 am

All times are UTC




Post new topic Reply to topic  [ 12 posts ] 
Author Message
PostPosted: Sun Nov 15, 2009 10:11 pm 
Offline
iris2-developer
User avatar

Joined: Tue Apr 18, 2006 10:28 pm
Posts: 823
Location: Munich, Bavaria, Germany
just got a report that the updater is returning an error, hagish,sience : any idea about that ?


Top
 Profile  
 
PostPosted: Sun Nov 15, 2009 10:33 pm 
Offline

Joined: Sun Nov 15, 2009 10:14 pm
Posts: 4
Goulsblade reported it for me but here are some more details :
Windows XP 64, not needing/using any http proxy, SVN is working fine for other projects, install went fine.
Image
Image

Also it asked me a file at first and I'm not sure which file it was looking for. It might be quite obvious for you but the install guide stops before explaining that.

(and a lot less important but I could not use the forum image upload feature to put those screenshot, phpbb tells me that my images are invalid)

Edit : but the client is running OK beside that after testing it for a few minutes


Top
 Profile  
 
PostPosted: Mon Nov 16, 2009 7:58 am 
Offline
iris2-developer
User avatar

Joined: Mon Aug 09, 2004 12:20 pm
Posts: 1431
Did the Updater has write rights in Iris2\bin directory?

_________________
http://crankgaming.blogspot.com/ | https://twitter.com/#!/crank_gaming


Top
 Profile  
 
PostPosted: Mon Nov 16, 2009 9:41 am 
Offline

Joined: Sun Nov 15, 2009 10:14 pm
Posts: 4
SiENcE wrote:
Did the Updater has write rights in Iris2\bin directory?

Yes (admin account, nothing readonly...). Anyway, it looks like a message returned from the server.


Top
 Profile  
 
PostPosted: Mon Nov 16, 2009 7:35 pm 
Offline
iris2-developer
User avatar

Joined: Mon Aug 09, 2004 12:20 pm
Posts: 1431
On the left side we display a webpage with changelog infos. But this website is currently offline (due a servercrash).

Does the Updater work?

_________________
http://crankgaming.blogspot.com/ | https://twitter.com/#!/crank_gaming


Top
 Profile  
 
PostPosted: Mon Nov 16, 2009 8:19 pm 
Offline

Joined: Sun Nov 15, 2009 10:14 pm
Posts: 4
I guess the message on the right "failed to display HTML document" is the failure for info display, but although it show "update finished", the update does not seem ok. If it's a temporary error caused by a server failure i guess i can wait.

Beside that, 2d seems OK, 3d does not work so far, maybe because of the failed update :
---------------------------
Error!
---------------------------
LuaError
error running function `Main': ../lua/lib.granny.lua:89: ERROR bodyinfo for skeleton not found 400
LuaStackTrace:

[C]: in function `assert'
../lua/lib.granny.lua:89: in function `GetOrCreateSkeleton'
../lua/lib.bodygfx.lua:286: in function `CreateBodyGfxPartsFromModelIDArray'
../lua/lib.bodygfx.lua:155: in function `Update'
../lua/lib.3d.dynamic.lua:304: in function `AddCorpseItem'
../lua/lib.3d.dynamic.lua:336: in function `AddDynamicItem'
../lua/obj/obj.dynamic.lua:157: in function `Update'
../lua/obj/obj.dynamic.lua:76: in function `CreateOrUpdateDynamic'
../lua/net/net.dynamic.lua:92: in function `handler'
../lua/lib.protocol.lua:70: in function `HandlePacket'
../lua/lib.protocol.lua:49: in function `HandlePackets'
..//lua/main.lua:619: in function `MainStep'
..//lua/main.lua:497: in function <..//lua/main.lua:385>
If this error remains after running the updater and you think this is a bug
please check the BugTracker at www.iris2.de
and report it if it is not already known.
Please also append the logfile in bin/stacktrace.log to your bugreport.
---------------------------
OK
---------------------------

But it's strange i was the only one to report it. I was under the impression that iris2 was quite more popular and old, or is it still a bit experimental and geek-only project ? ;)

Regards,

superpenguin


Top
 Profile  
 
PostPosted: Mon Nov 16, 2009 9:18 pm 
Offline
iris2-developer
User avatar

Joined: Mon Aug 09, 2004 12:20 pm
Posts: 1431
superpenguin wrote:
But it's strange i was the only one to report it. I was under the impression that iris2 was quite more popular and old, or is it still a bit experimental and geek-only project ? ;)


Think of it what you want, but i think you don't read the install instructions or our hints on our webpage ;-).

"you also need to install UO:ML Client (choose one):
* UO:Mondain's Legacy (mirror1)
* or UO:Mondain's Legacy (mirror2)
* or UO:Mondain's Legacy (fileplanet)
* or more"

-> http://iris.schattenkind.net/index.php/ ... on_Windows

Iris2 3D Mode need the 3d character models from the legacy abbadon UO:3d Client.

_________________
http://crankgaming.blogspot.com/ | https://twitter.com/#!/crank_gaming


Top
 Profile  
 
PostPosted: Mon Nov 16, 2009 9:54 pm 
Offline
iris2-developer
User avatar

Joined: Tue Apr 18, 2006 10:28 pm
Posts: 823
Location: Munich, Bavaria, Germany
The iris project in total is a few years old, but iris2 started as complete rewrite from scratch around 2 years ago, and userfriendlyness still needs a lot more polish.
Also due to a recent server crash, we had to move a few things to another server and adjust the urls, which led to the recent updater problems, we're working on it though =)
(the utf8 error should be fixed already)

note for bug : the 405 error is due to the updater using the svn paths :
20 const char *gszRepos_Unstable = "http://iris.schattenkind.net/svn/trunk";
21 const char *gszRepos_Stable = "http://iris.schattenkind.net/svn/branches/stable_release";
which result currently in an error when used directly with svn, this is most likely a apache-svn/webdav issue created when we moved the wiki to that url, hagish started working on it.


Top
 Profile  
 
PostPosted: Mon Nov 16, 2009 10:20 pm 
Offline

Joined: Sun Nov 15, 2009 10:14 pm
Posts: 4
SiENcE wrote:
Think of it what you want, but i think you don't read the install instructions or our hints on our webpage ;-).

I did RTFM, sorry that i did not found where it was indicated that you have to use a specific 3d version. However I had already downloaded UOML from the official uo.com website, "setup-1.46.0.3.exe", i hope it's the right one.

Since the 3D client is not supported by EA on the newest versions, when you patch UOML, you lose the ability to use the 3d client. I was away from uo a long time so i'm not 100% sure of all of that but that's my understanding. Am i doomed, or is this still OK that the 3d client does not exists ?


(EDIT: After a bit more experimentation...)


I did a svn switch --relocate to fix the repo location and then switched again from stable to trunk. Iris is now loading in 3D mode, it looks cool, but with some other serious usability issues (all PC / NPC are invisible, stack trace bellow, roof / ceiling level sometime wrong...)

Code:
Renderer3D:MapAreaCheck 1337    1727    false
Renderer3D:MapAreaCheck 1335    1724    false
lugre_error     pcall error in NotifyListener   ../lua/lib.granny.lua:90: ERROR
bodyinfo for skeleton not found 401
stack traceback:
        [C]: in function 'assert'
        ../lua/lib.granny.lua:90: in function 'GetOrCreateSkeleton'
        ../lua/lib.bodygfx.lua:295: in function 'CreateBodyGfxPartsFromModelIDAr
ray'
        ../lua/lib.bodygfx.lua:164: in function 'Update'
        ../lua/lib.bodygfx.lua:379: in function 'Step'
        ../lua/lib.bodygfx.lua:32: in function 'BodyGfxMainStep'
        ../lua/lib.bodygfx.lua:29: in function <../lua/lib.bodygfx.lua:29>
        (tail call): ?
        [C]: in function 'xpcall'
        ..//lugre/lua/lib.util.lua:238: in function 'lugrepcall'
        ..//lugre/lua/lib.listener.lua:52: in function 'NotifyListener'
        ..//lua/main.lua:676: in function 'MainStep'
        ..//lua/main.lua:505: in function <..//lua/main.lua:391>

Renderer3D:MapAreaCheck 1334    1728    false
lugre_error     pcall error in NotifyListener   ../lua/lib.granny.lua:90: ERROR
bodyinfo for skeleton not found 401
(...)



ghouls: thanks for the explanation. I hope you will be able to do a few tests from a "user point of view" after the server problem has been resolved.


Top
 Profile  
 
PostPosted: Tue Nov 17, 2009 7:48 am 
Offline
iris2-developer
User avatar

Joined: Mon Aug 09, 2004 12:20 pm
Posts: 1431
superpenguin wrote:
Since the 3D client is not supported by EA on the newest versions, when you patch UOML, you lose the ability to use the 3d client. I was away from uo a long time so i'm not 100% sure of all of that but that's my understanding. Am i doomed, or is this still OK that the 3d client does not exists ?


If you take the right UO:ML version using our Links, then you get the old 3d client too and you are able to update to the current UO:SA Version too. You do not loose the 3d models, because they don't delete this models.

The only problem might be, that they introduced new monsters and animation, but they also used a new fileformat (uop) for that. So iris2 is currently only able to support UO:KR and not the UO:SA map5 (you can view it, but most items are invisible).

The message:

"lugre_error pcall error in NotifyListener ../lua/lib.granny.lua:90: ERROR
bodyinfo for skeleton not found 401"

tells me, that Iris2 still can't find the 3d (granny) models or skeleton! If you took the "setup-1.46.0.3.exe" from the osi website, then you don't have the 3d models in it, because osi removed them form thier uo:ml installer.

It's why i said, read the instructions carefully. Take one of our links to an UO:ML installer.

_________________
http://crankgaming.blogspot.com/ | https://twitter.com/#!/crank_gaming


Top
 Profile  
 
PostPosted: Tue Nov 17, 2009 8:24 am 
Offline
iris2-developer
User avatar

Joined: Tue Apr 18, 2006 10:28 pm
Posts: 823
Location: Munich, Bavaria, Germany
The big secret is the installer on the official uo website doesn't have the 3d-model files, but the older installers we linked does have them. Patching uo does not remove the model files themselves, only the original 3dclient.exe, which isn't needed by iris.

If you wouldn't mind, please point out a few things that are annoying/irritating/problematic from a users point of view.
For us devs it's sometimes hard to judge which problems in that regard are most important.


Top
 Profile  
 
PostPosted: Tue Nov 17, 2009 7:01 pm 
Offline
iris2-developer
User avatar

Joined: Tue Apr 18, 2006 10:28 pm
Posts: 823
Location: Munich, Bavaria, Germany
updater problem fixed ! ( http://iris.schattenkind.net/svn/ is working again )


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 12 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group