Can't compile (Ubuntu)
Page 1 of 1

Author:  iuri_BR [ Thu Dec 22, 2011 2:20 am ]
Post subject:  Can't compile (Ubuntu)

I try to compile iris2 in Ubuntu GNU/Linux distribution but i get an error. LD_FLAGS of iris.make uses `pkg-config --libs x11`.
Linking iris
/usr/bin/ld: ./liblugreois.a(LinuxKeyboard.o): undefined reference to symbol 'XGrabKeyboard'
/usr/bin/ld: note: 'XGrabKeyboard' is defined in DSO /usr/lib/i386-linux-gnu/ so try adding it to the linker command line
/usr/lib/i386-linux-gnu/ could not read symbols: Invalid operation
collect2: ld returned 1 exit status
make[1]: ** [bin/iris] Erro 1
make: ** [iris] Erro 2

Author:  ghoulsblade [ Thu Dec 22, 2011 8:04 pm ]
Post subject:  Re: Can't compile (Ubuntu)

i'm on ubuntu natty 64 bit, and compile works fine here.
be sure to update to trunk rather than latest-stable,
and run ./
and read the instructions being output since a few things have to be done manually

Author:  Jarlakxen [ Tue Jan 10, 2012 3:49 pm ]
Post subject:  Re: Can't compile (Ubuntu)

I have the same problem in Ubuntu 11.10. I tried with the trunk and with the latest-stable but i had the same error.

Page 1 of 1 All times are UTC
Powered by phpBB® Forum Software © phpBB Group