Iris2.de

Iris2-Forum
It is currently Tue Oct 27, 2020 11:38 am

All times are UTC




Post new topic Reply to topic  [ 9 posts ] 
Author Message
 Post subject: lua popen error
PostPosted: Wed Sep 03, 2008 12:26 am 
Offline

Joined: Tue Sep 02, 2008 7:26 pm
Posts: 9
anyone?

Code:
nt@eNTi $ ./start.sh                                                                                                                                                                     
~/abs/iris2/src/iris2/bin ~/abs/iris2/src/iris2                                                                                                                                           
MainWorkingDir  ../                                                                                                                                                                       
lugreluapath    ../lugre/lua/                                                                                                                                                             
Setting Graphicprofile: ../data/profiles/gfx_ultrahigh.lua                                                                                                                               
Lua version : 5.1                                                                                                                                                                         
loading plugin  ../plugins/example.lua                                                                                                                                                   
loading plugin  ../plugins/hudenemylist.lua                                                                                                                                               
LuaErrorHandler start                                                                                                                                                                     

LuaErrorHandler end
lugre/src/lugre_main.cpp:182:Lugre_Run
lugre/src/lugre_game.cpp:19:Run
  lugre/src/lugre_scripting.cpp:263:LuaCall
   lugre/src/lugre_scripting.cpp:209:LuaErrorHandler
PrintLuaStackTrace:
LuaStackTrace:

ERROR : LuaError
error running function `Main': ../lugre/lua/lugre.lua:9: 'popen' not supported
LuaStackTrace:

        [C]: in function `popen'
        ../lugre/lua/lugre.lua:9: in function `lugre_detect_ogre_plugin_path'
        ../lua/main.lua:297: in function <../lua/main.lua:276>
If this error remains after running the updater and you think this is a bug
please check the BugTracker at www.iris2.de
and report it if it is not already known.
Please also append the logfile in bin/stacktrace.log to your bugreport.
./start.sh: line 5: 16032 Aborted                 ./iris $1 $2 $3 $4 $5 $6 $7 $8
~/abs/iris2/src/iris2


Top
 Profile  
 
 Post subject:
PostPosted: Wed Sep 03, 2008 11:17 am 
Offline
iris2-developer
User avatar

Joined: Tue Apr 18, 2006 10:28 pm
Posts: 823
Location: Munich, Bavaria, Germany
what operating system are you using ? win,mac,linux ? 64bit maybe ?


Top
 Profile  
 
 Post subject:
PostPosted: Wed Sep 03, 2008 11:57 am 
Offline

Joined: Tue Sep 02, 2008 7:26 pm
Posts: 9
sorry. i'm on archlinux, 32bit. a friend of mine uses arch on 64bit and doesn't have that problem.


Top
 Profile  
 
 Post subject:
PostPosted: Wed Sep 03, 2008 1:00 pm 
Offline
iris2-developer
User avatar

Joined: Tue Aug 22, 2006 1:21 pm
Posts: 173
Location: Munich, Germany
how did you compile iris? because it looks like that your lua is compiled without popen.

_________________
O-->---


Top
 Profile  
 
 Post subject:
PostPosted: Thu Sep 04, 2008 1:50 pm 
Offline

Joined: Tue Sep 02, 2008 7:26 pm
Posts: 9
well... i installed lua 5.1.4 from the package management system and i didn't really change anything special before i compiled iris. where do i turn on/off the popen compilation? does iris come with it's own lua build and if so, where i can i set it to use the system-wide lua libs?

i've seen, that there are two versions of lua in the package database, maybe there's a reason for that? the other one is 5.1.3 and i've read somewhere that it's a req for iris. i thought 5.1.4 would be backwards compatible.


Top
 Profile  
 
 Post subject:
PostPosted: Thu Sep 04, 2008 2:44 pm 
Offline
iris2-developer
User avatar

Joined: Tue Apr 18, 2006 10:28 pm
Posts: 823
Location: Munich, Bavaria, Germany
iris comes with it's own lua build, no need to install it via package system.
the recommended way to compile iris is ./premakelinux.sh

maybe try uninstalling the lua lib you installed via package system, and then recompile iris.


Top
 Profile  
 
 Post subject:
PostPosted: Thu Sep 04, 2008 5:33 pm 
Offline

Joined: Tue Sep 02, 2008 7:26 pm
Posts: 9
i did compile it with premakelinux.sh. i'm afraid i can't uninstall lua, i need it for other things and it's as dependency in the system. isn't there another way?


Top
 Profile  
 
 Post subject:
PostPosted: Thu Sep 04, 2008 6:09 pm 
Offline
iris2-developer
User avatar

Joined: Tue Apr 18, 2006 10:28 pm
Posts: 823
Location: Munich, Bavaria, Germany
hmm iris should be using the compiled in lua then, strange.

as a workaround :
execute "pkg-config --variable=plugindir OGRE" manually
(or look for where the ogre plugins were installed),
and add a line to data/config.lua like

gOgrePluginPathOverride = "/usr/local/lib/OGRE"

or so


Top
 Profile  
 
 Post subject:
PostPosted: Thu Sep 04, 2008 7:01 pm 
Offline

Joined: Tue Sep 02, 2008 7:26 pm
Posts: 9
yeah... that worked. :) thx.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 9 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group