Iris2.de

Iris2-Forum
It is currently Tue Oct 27, 2020 12:30 pm

All times are UTC




Post new topic Reply to topic  [ 17 posts ]  Go to page 1, 2  Next
Author Message
PostPosted: Mon Nov 03, 2008 10:30 pm 
Offline

Joined: Mon Nov 03, 2008 10:27 pm
Posts: 10
I am really pretty new to linux. I am taking it as part of my college course. I have fallen in love with linux, and I have switched completely from xp and vista. However, I am still learning it, and I am confused. I tried to install iris 2. Here is what I did

rune@Greed:~/iris_2.0.2525$ ./premakelinux.sh
Removing all project and intermediate files...
disabled asserts (NDEBUG)
Generating GNU makefiles:
...lugrelua
...md5lib
...caelumlib
...lugrelib
...iris
==== Building lugrelua ====
lparser.c
lvm.c
loslib.c
lgc.c
lundump.c
ltable.c
ltablib.c
liolib.c
lstrlib.c
loadlib.c
lzio.c
ldo.c
ldump.c
print.c
ltm.c
lua.c
lmathlib.c
lmem.c
lauxlib.c
lapi.c
luac.c
lcode.c
lstate.c
lstring.c
ldebug.c
lobject.c
llex.c
linit.c
lbaselib.c
ldblib.c
lfunc.c
lopcodes.c
Linking lugrelua
==== Building md5lib ====
md5.c
Linking md5lib
==== Building caelumlib ====
DepthComposer.cpp
/bin/sh: ccache: not found
make[1]: *** [obj/Release/DepthComposer.o] Error 127
make: *** [caelumlib] Error 2
I am really confused as to what this is and means. I am using 64 bit ubuntu, and I am running kde 4.1. Thanks everyone. I guess I am looking for help installing this.


Top
 Profile  
 
 Post subject:
PostPosted: Tue Nov 04, 2008 12:34 am 
Offline
iris2-developer
User avatar

Joined: Tue Apr 18, 2006 10:28 pm
Posts: 823
Location: Munich, Bavaria, Germany
hi and welcome =)

since you're using a 64 bit system, i'd suggest using the latest iris version, as we recently added a few 64bit fixes.
to do that do the following :

sudo apt-get install subversion

svn co http://iris.schattenkind.net/svn/trunk/ iris
(creates a new folder named "iris" in the current dir, and downloads the latest iris version)

cd iris

./installdeps.ubuntu.sh
(this should install all dependencies)

./premakelinux.sh
(if ccache still causes trouble, try ./premakelinux_noccache.sh instead)

./start.sh
(to start iris after the compile)



before doing the iris part, you'll need to install uo-mondains-legacy trial, as iris needs some of the game data.
you can find a working version including 3d models here :
http://games.mirrors.tds.net/pub/ea-gam ... _setup.exe
(one of the links on our website on the right)


Top
 Profile  
 
 Post subject:
PostPosted: Tue Nov 04, 2008 1:07 am 
Offline

Joined: Mon Nov 03, 2008 10:27 pm
Posts: 10
Thank you very much.

I have another question. I was following the steps and it came to this

In file included from /usr/include/c++/4.3/ext/hash_map:64,
from /usr/include/OGRE/OgreStdHeaders.h:38,
from /usr/include/OGRE/OgreMemoryManager.h:46,
from /usr/include/OGRE/OgrePrerequisites.h:87,
from /usr/include/OGRE/Ogre.h:32,
from include/builder.h:4,
from include/data_common.h:4,
from src/data_gump.cpp:1:
/usr/include/c++/4.3/backward/backward_warning.h:33:2: warning: #warning This file includes at least one deprecated or antiquated header which may be removed without further notice at a future date. Please use a non-deprecated interface with equivalent functionality instead. For a listing of replacement headers and interfaces, consult the file backward_warning.h. To disable this warning use -Wno-deprecated.



What does this mean. Is it okay to ignore it. How do I turn off the warning. Thank you ghoul


Top
 Profile  
 
 Post subject:
PostPosted: Tue Nov 04, 2008 1:10 am 
Offline

Joined: Mon Nov 03, 2008 10:27 pm
Posts: 10
when I ran start it gave me this message.

rune@Greed:~/iris$ ./start.sh
~/iris/bin ~/iris
MainWorkingDir ../
lugreluapath ../lugre/lua/
gGraphicProfile shadow med
Setting Graphicprofile: ../data/profiles/gfx_med.lua
Lua version : 5.1
loading plugin ../plugins/example.lua
loading plugin ../plugins/hudenemylist.lua
loading plugin ../plugins/lib.spellbar.lua
loading plugin ../plugins/loot.lua
loading plugin ../plugins/moblist.lua
ogre::exception
OGRE EXCEPTION(7:InternalErrorException): Could not load dynamic library /usr/lib/OGRE/Plugin_CgProgramManager.so. System Error: /usr/lib/OGRE/Plugin_CgProgramManager.so: cannot open shared object file: No such file or directory in DynLib::load at OgreDynLib.cpp (line 80)
lugre/src/lugre_main.cpp:189:Lugre_Run
PrintLuaStackTrace:
LuaStackTrace:

[C]: in function `InitOgre'
../lua/main.lua:345: in function <../lua/main.lua:310>
ERROR : Ogre::exception occurred, see console
OGRE EXCEPTION(7:InternalErrorException): Could not load dynamic library /usr/lib/OGRE/Plugin_CgProgramManager.so. System Error: /usr/lib/OGRE/Plugin_CgProgramManager.so: cannot open shared object file: No such file or directory in DynLib::load at OgreDynLib.cpp (line 80)
If this error remains after running the updater and you think this is a bug
please check the BugTracker at www.iris2.de
and report it if it is not already known.
Please also append the logfile in bin/stacktrace.log to your bugreport.
./start.sh: line 5: 22087 Aborted ./iris $1 $2 $3 $4 $5 $6 $7 $8
~/iris


Top
 Profile  
 
 Post subject:
PostPosted: Tue Nov 04, 2008 2:08 am 
Offline
iris2-developer
User avatar

Joined: Tue Apr 18, 2006 10:28 pm
Posts: 823
Location: Munich, Bavaria, Germany
@warning : you can ignore that

@execption at startup : hmm, i was hoping that one wouldn't come.

quick solution
* edit bin/plugins_linux.cfg
* remove the line Plugin=Plugin_CgProgramManager.so
(the drawback is that the water shader and skysystem won't work, but it's not that important)

longer solution :
if you want you can also also fix this by compiling ogre 1.4.9 yourself (we don't fully support 1.6.* yet i think), but it might be a bit tricky
http://downloads.sourceforge.net/ogre/o ... -9.tar.bz2


Top
 Profile  
 
 Post subject: Thank you
PostPosted: Tue Nov 04, 2008 3:10 am 
Offline

Joined: Mon Nov 03, 2008 10:27 pm
Posts: 10
I have to say the linux crowd is very very helpful. I cannot believe the amount of time and effort the linux groups gives to help make linux what it is.


Top
 Profile  
 
 Post subject: Where is the audio
PostPosted: Tue Nov 04, 2008 5:26 am 
Offline

Joined: Mon Nov 03, 2008 10:27 pm
Posts: 10
I am wondering how to enable my audio in this game. It works on everything else. I am using the alsa sigmatel driver I believe. Thank you. BTW this game is great.


Top
 Profile  
 
 Post subject:
PostPosted: Tue Nov 04, 2008 9:58 am 
Offline
iris2-developer
User avatar

Joined: Tue Aug 22, 2006 1:21 pm
Posts: 173
Location: Munich, Germany
if you start the game is there a line like

SoundInit(openal,22050.000000)

in the console?
if you dont mind non free components the easiest is to install fmod ( http://www.fmod.org/index.php/download# ... rammersAPI ).

_________________
O-->---


Top
 Profile  
 
 Post subject:
PostPosted: Tue Nov 04, 2008 1:38 pm 
Offline

Joined: Mon Nov 03, 2008 10:27 pm
Posts: 10
No there is not. I checked, and I don't see it. I get a humm from my headphones. Is there a way I can fix this. I play enemy territory and quake 4 just fine with audio. Thanks for help


Top
 Profile  
 
 Post subject:
PostPosted: Tue Nov 04, 2008 3:32 pm 
Offline
iris2-developer
User avatar

Joined: Tue Aug 22, 2006 1:21 pm
Posts: 173
Location: Munich, Germany
goto fmod.org and download:

fmod 4.* (FMOD Ex Version: 4.14.03 stable) ( http://www.fmod.org/ )

or a newer version. but it needs to be Ex.
i extracted mine into /usr/src/fmodapi40619linux
in this directory there is a Makefile
you need to execute

sudo make install

inside of directory and after that rebuild iris
the way you did it the first time.

finally you need to add

gUseSoundSystem = "fmod"

to your config.lua file.

_________________
O-->---


Top
 Profile  
 
 Post subject:
PostPosted: Tue Nov 04, 2008 4:22 pm 
Offline

Joined: Mon Nov 03, 2008 10:27 pm
Posts: 10
I followed your instructions

rune@Greed:~/fmodapi42000linux64$ sudo make install
Installing FMOD Ex libraries and headers...
cp -f api/lib/libfmodex64.so.4.20.00 /usr/local/lib
cp -f api/lib/libfmodexp64.so.4.20.00 /usr/local/lib
ln -s /usr/local/lib/libfmodex64.so.4.20.00 /usr/local/lib/libfmodex64.so
ln: creating symbolic link `/usr/local/lib/libfmodex64.so': File exists
make: *** [install] Error 1
rune@Greed:~/fmodapi42000linux64$

I think rebuilt the game

I still get a humm sound in my speakers. There is still no audio. The terminal loads Fmod. I really don't know what to do. Thank you


Top
 Profile  
 
PostPosted: Tue Nov 04, 2008 9:20 pm 
Offline

Joined: Mon Nov 03, 2008 10:27 pm
Posts: 10
I appreciate your help. I installed openal on this linux box. With Cmake. I went to config.lua, and I added openal. I then get this error in the box

Loading Map name Felucca
Loading Map terrain /home/rune/.wine/drive_c/Program Files/EA Games/Ultima Online Mondain's Legacy/map0.mul
cFullFileLoader(/home/rune/.wine/drive_c/Program Files/EA Games/Ultima Online Mondain's Legacy/map0.mul) : 85.8 MB
Loading Static static idx /home/rune/.wine/drive_c/Program Files/EA Games/Ultima Online Mondain's Legacy/staidx0.mul
Loading Static static /home/rune/.wine/drive_c/Program Files/EA Games/Ultima Online Mondain's Legacy/statics0.mul
cFullFileLoader(/home/rune/.wine/drive_c/Program Files/EA Games/Ultima Online Mondain's Legacy/statics0.mul) : 21.2 MB
cFullFileLoader(/home/rune/.wine/drive_c/Program Files/EA Games/Ultima Online Mondain's Legacy/staidx0.mul) : 5.2 MB
cStaticBlockLoader_IndexedFullFile miMapW=896
DEBUG /home/rune/.wine/drive_c/Program Files/EA Games/Ultima Online Mondain's Legacy/map0.mul fc97b6fb247559cad54ee4cf7c48250f
DEBUG /home/rune/.wine/drive_c/Program Files/EA Games/Ultima Online Mondain's Legacy/staidx0.mul 23655ce6b4aa4ef29b4b24e9c7ec28ad
DEBUG /home/rune/.wine/drive_c/Program Files/EA Games/Ultima Online Mondain's Legacy/statics0.mul 49ad09a228e37b084bbbddfdd3ada7d5
../data/tmp/compass_4b102f015fb6634609945dea0ba09eb3_small_s.png exists
Welcome to Iris
OpenAL: Unsupported file type: /home/rune/.wine/drive_c/Program Files/EA Games/Ultima Online Mondain's Legacy/Music/Digital/ConversationWithGwenno.mp3
ERROR something went wrong: /home/rune/.wine/drive_c/Program Files/EA Games/Ultima Online Mondain's Legacy/Music/Digital/ConversationWithGwenno.mp3
Send_DoubleClick 0x413c7815


Top
 Profile  
 
 Post subject:
PostPosted: Wed Nov 05, 2008 9:00 am 
Offline
iris2-developer
User avatar

Joined: Tue Aug 22, 2006 1:21 pm
Posts: 173
Location: Munich, Germany
with openal you can only hear the sounds. currently there is no mp3 decoder for openal at the moment and therefore you cant play the background music.

_________________
O-->---


Top
 Profile  
 
 Post subject:
PostPosted: Wed Nov 05, 2008 2:17 pm 
Offline
iris2-developer
User avatar

Joined: Tue Apr 18, 2006 10:28 pm
Posts: 823
Location: Munich, Bavaria, Germany
there's a script iris/scripts/repairmusic.sh,
it can be used to reencode the uo music, so that openal can play them. you probably need to run it in the uo music dir, be sure to make a backup of the dir before you run it.
The original uo files use some strange old mp3 variant that openal seems to have problems with, with this script you can reencode them to so that openal can load them.


Top
 Profile  
 
 Post subject:
PostPosted: Wed Nov 05, 2008 9:24 pm 
Offline

Joined: Mon Nov 03, 2008 10:27 pm
Posts: 10
My problem is this. I can't hear anything with iris 2. I can't hear sound, or music. This is with Fmod, and openal. I am at a loss. Sound works in everything else...


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 17 posts ]  Go to page 1, 2  Next

All times are UTC


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group