Iris2.de

Iris2-Forum
It is currently Mon Oct 26, 2020 4:49 am

All times are UTC




Post new topic Reply to topic  [ 2 posts ] 
Author Message
PostPosted: Sat Dec 19, 2009 6:47 am 
Offline

Joined: Sat Dec 19, 2009 6:37 am
Posts: 4
seems i cant install iris =\
let me show you guys what error i got...

Quote:
sound: openal
sound: fmod
OIS platform: linux (lugre)
AddLugreDeps: fmod in defines: true
searching for /usr/local/lib64//libfmodex.so/.a false false
searching for /usr/local/lib//libfmodex.so/.a false false
searching for /usr/lib64//libfmodex.so/.a false false
searching for /usr/lib//libfmodex.so/.a false false
WARNING:addcustomlib fmodex libfile not found
if you installed the 64 bit version, please try installing the 32 bit version instead
using /usr/local/include/fmodex as fmodex include path
AddLugreDeps: fmod in defines: true
searching for /usr/local/lib64//libfmodex.so/.a false false
searching for /usr/local/lib//libfmodex.so/.a false false
searching for /usr/lib64//libfmodex.so/.a false false
searching for /usr/lib//libfmodex.so/.a false false
WARNING:addcustomlib fmodex libfile not found
if you installed the 64 bit version, please try installing the 32 bit version instead
using /usr/local/include/fmodex as fmodex include path
Removing all project and intermediate files...
root@knaakpc:/usr/local/src/iris# ./premakelinux.sh
3
>>> disabled asserts (NDEBUG)
sound: openal
sound: fmod
OIS platform: linux (lugre)
AddLugreDeps: fmod in defines: true
searching for /usr/local/lib64//libfmodex.so/.a false false
searching for /usr/local/lib//libfmodex.so/.a false false
searching for /usr/lib64//libfmodex.so/.a false false
searching for /usr/lib//libfmodex.so/.a false false
WARNING:addcustomlib fmodex libfile not found
if you installed the 64 bit version, please try installing the 32 bit version instead
using /usr/local/include/fmodex as fmodex include path
2.8.9
AddLugreDeps: fmod in defines: true
searching for /usr/local/lib64//libfmodex.so/.a false false
searching for /usr/local/lib//libfmodex.so/.a false false
searching for /usr/lib64//libfmodex.so/.a false false
searching for /usr/lib//libfmodex.so/.a false false
WARNING:addcustomlib fmodex libfile not found
if you installed the 64 bit version, please try installing the 32 bit version instead
using /usr/local/include/fmodex as fmodex include path
2.8.9
Generating GNU makefiles:
...lugrelua
...lugreois
...md5lib
...caelumlib
...lugrelib
...iris
==== Building lugrelua ====
==== Building lugreois ====
==== Building md5lib ====
OISEffect.cpp
ldo.c
ldo.c
OISKeyboard.cpp
lzio.c
lzio.c
lfunc.c
lfunc.c
lua.c
In file included from lugre/lib/lua-5.1.4//src/lua.h:16,
from lugre/lib/lua-5.1.4//src/lua.c:15:
lugre/lib/lua-5.1.4//src/luaconf.h:275:31: warning: readline/readline.h: Arquivo ou diretório inexistente -> File or Directory inexists
lugre/lib/lua-5.1.4//src/luaconf.h:276:30: warning: readline/history.h: Arquivo ou diretório inexistente
lugre/lib/lua-5.1.4//src/lua.c: In function ‘pushline’:
lugre/lib/lua-5.1.4//src/lua.c:182: warning: assignment makes pointer from integer without a cast
lua.c
In file included from lugre/lib/lua-5.1.4//src/lua.h:16,
from lugre/lib/lua-5.1.4//src/lua.c:15:
lugre/lib/lua-5.1.4//src/luaconf.h:275:31: warning: readline/readline.h: Arquivo ou diretório inexistente
lugre/lib/lua-5.1.4//src/luaconf.h:276:30: warning: readline/history.h: Arquivo ou diretório inexistente
lugre/lib/lua-5.1.4//src/lua.c: In function ‘pushline’:
lugre/lib/lua-5.1.4//src/lua.c:182: warning: assignment makes pointer from integer without a cast
OISException.cpp
lstring.c
loslib.c
lapi.c
lstring.c
OISInputManager.cpp
lapi.c
ldebug.c
ldebug.c
lvm.c
lvm.c
OISJoyStick.cpp
ltablib.c
loadlib.c
lstrlib.c
OISForceFeedback.cpp
ltablib.c
OISObject.cpp
LinuxInputManager.cpp
lstrlib.c
lparser.c
lparser.c
ldblib.c
linit.c
ltable.c
ldblib.c
LinuxForceFeedback.cpp
ldump.c
ltable.c
luac.c
ldump.c
LinuxMouse.cpp
luac.c
ltm.c
ltm.c
lmathlib.c
lmathlib.c
lbaselib.c
LinuxKeyboard.cpp
lbaselib.c
lgc.c
lgc.c
liolib.c
liolib.c
lstate.c
lauxlib.c
lstate.c
EventHelpers.cpp
lobject.c
lauxlib.c
llex.c
lcode.c
lobject.c
lcode.c
lmem.c
lundump.c
lmem.c
print.c
lundump.c
lopcodes.c
Linking lugrelua
LinuxJoyStickEvents.cpp
print.c
==== Building caelumlib ====
CaelumPrecompiled.cpp
md5.c
Linking md5lib
CaelumDefaultTypeDescriptorData.cpp
Linking lugreois
GeometryFactory.cpp
FlatCloudLayer.cpp
SkyLight.cpp
DepthComposer.cpp
UniversalClock.cpp
Astronomy.cpp
PrecipitationController.cpp
TypeDescriptor.cpp
BrightStarCatalogue.cpp
CaelumScriptTranslator.cpp
GroundFog.cpp
SkyDome.cpp
CaelumSystem.cpp
Moon.cpp
ImageHelper.cpp
CaelumPlugin.cpp
CameraBoundElement.cpp
Sun.cpp
ImageStarfield.cpp
PointStarfield.cpp
CloudSystem.cpp
Linking caelumlib
==== Building lugrelib ====
lugre_thread_L.cpp
lugre_rendertexture_L.cpp
lugre_gfx2D.cpp
lugre_luaxml.cpp
lugre_ode.cpp
lugre_game.cpp
lugre_meshloader.cpp
lugre_widget_L.cpp
lugre_scripting.cpp
lugre_fastbatch.cpp
lugre_beam_L.cpp
lugre_luabinds_ogre.cpp
lugre_beam.cpp
lugre_gfx3D_L.cpp
lugre/src/lugre_luabinds_ogre.cpp: In static member function ‘static int Lugre::cLugreLuaBind_Ogre_MovableObject::RegisterMethods(lua_State*)::cTempClass::getReceivesShadows(lua_State*)’:
lugre/src/lugre_luabinds_ogre.cpp:766: error: ‘class Ogre::MovableObject’ has no member named ‘getReceivesShadows’
make[1]: ** [obj/Release/lugre_luabinds_ogre.o] Erro 1
make[1]: ** Esperando que outros processos terminem. ---- > translate: Waiting for other process to finish
make: ** [lugrelib] Erro 2


pls help.
Thank you


Top
 Profile  
 
PostPosted: Sat Dec 19, 2009 10:23 am 
Offline
iris2-developer
User avatar

Joined: Tue Apr 18, 2006 10:28 pm
Posts: 823
Location: Munich, Bavaria, Germany
Quote:
class Ogre::MovableObject’ has no member named ‘getReceivesShadows’

seems like your ogre version is too old, current is 1.6.4.
you can see which you have with
Code:
cat /usr/local/include/OGRE/OgrePrerequisites.h | grep "define OGRE_VERSION"


i'll try to disbale the line that throws an error, so if you update in a little while, the error might be solved as well.
will only work if you use trunk, not on the stable branch.

also please see ./installdeps.ubuntu.sh for how to deal with the fmod error message :
Quote:
FMOD
iris 2 uses fmod ex 4.* to play music files. alternatively you can use openal, but that has no music then.
you can download fmod ex 4.* stable for linux from http://www.fmod.org/index.php/download
please install the 32 bit version of fmod, even if you have a 64 bit system, our buildscript wont be able to find it otherwise
direct download link (august 2009) : http://www.fmod.org/index.php/release/v ... nux.tar.gz
you probably have to add a symbolic link so that iris can find the fmod lib, since the filename contains the version
to do that run
#> locate libfmod
if it lists something like /usr/local/lib/libfmodex-4.27.06.so
then you should make a symbolic link like this :
#> sudo ln -s /usr/local/lib/libfmodex-4.27.06.so /usr/local/lib/libfmodex.so
then iris will find it during compile : ./makeclean.sh && ./premakelinux.sh
if you get linker errors like 'undefined reference to ... FMOD_...' (64 bit problem) you can disable fmod by editing premake.lua and setting 'gbUseSoundFmod = true' to false


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group